Настройка Multi-active detection (MAD) на коммутаторах H3C (HP) (Comware)

Когда работает виртуальный коммутатор (как настроить виртуальное шасси, рассказывается в статье: Настройка IRF на коммутаторах H3C (HP) (Comware Software)), состоящий из двух и более физических коммутаторов, он через IRF порты определяет какой физический коммутатор главный и обнаруживает отказ, но что будет, если между коммутаторами прервётся связь по IRF портам? Они оба подумают, что второй перестал работать и оба станут главными, что приведёт к появлению двух одинаковых устройств в сети и, соответственно, общему сбою.Для того, чтобы такого не произошло, используется технология Multi-active detection (MAD).
Есть несколько реализаций проверки доступности:
LACP MAD — требуется третье устройство, подключенное к обоим коммутаторам. Коммутатор будет посылать запрос к стороннему устройству с идентификатором активного устройства. Если оба станут активными, то от каждого коммутатора будет пакет, что именно он активный. В этот момент они и узнают, что один нужно отключить (из плюсов данной технологии — самая быстра скорость рекции на отказ. Из минусов — требуется третий коммутатор, поддерживающий пересылку пакетов MAD);
BFD MAD — на уровне L2 создаётся прямое подключение между коммутаторами (из плюсов технологии — требуется только прямое L2 соединение между коммутаторами, из минусов — переключение происходит дольше, чем в случае LACP MAD);
ARP MAD — через запрос Gratuitous ARP, с идентификатором активного коммутатора;
ND MAD — с помощью пакетов NS (протокол Neighbor Discovery IPv6).

Вся настройка производилась на примере двух блейд-коммутаторов HP 6127XLG.

Настройка BFD MAD

Для начала соединяем пару интерфейсов между коммутаторами прямым соединением (можно соединять любые или использовать уже существующие (только не IRF порты). Трафика там практически не будет).

Далее создадим отдельный VLAN:

vlan 1000
description BFD_MAD
quit

Настроим VLAN:

interface Vlan-interface 1000

включаем MAD BFD:

mad bfd enable

Добавляем IP адреса для MAD (в нашей конфигурации всего 2 коммутатора, поэтому была выбрана сеть /30):

mad ip address 10.20.100.1 255.255.255.252 member 1
mad ip address 10.20.100.2 255.255.255.252 member 2

Выйдем из конфигурации Vlan интерфейса:

quit

Теперь настроим интерфейсы, через которые будет работать проверка (гибридный тип порта используется на случай появления дополнительного трафика по этому каналу, так что в принципе можно использовать и режим access):

В связи с тем что у нас IRF фабрика, мы можем настроить порты сразу на обоих коммутаторах:

interface range Ten-GigabitEthernet 1/0/18 Ten-GigabitEthernet 2/0/18

Используем режим L2:

port link-mode bridge

Создадим гибридные порты:

port link-type hybrid

Добавим порты в созданный MAD Vlan:

port hybrid vlan 1000 untagged
port hybrid pvid vlan 1000

выключим spanning tree:

undo stp enable

включаем порты:

undo shutdown

выходим из режима конфигурации портов:

quit

BFD MAD настроен.

Настройка LACP MAD

Для использования LACP MAD нам потребуется отдельный коммутатор, которы поддерживает lacp mad-passthrough.

Сначала настраиваем логическую группу для агрегации каналов и включим для нее MAD:

interface Bridge-Aggregation 1
link-aggregation mode dynamic
mad enable
quit

Назначим физические интерфейсы для логической группы агрегации каналов:

interface range Ten-GigabitEthernet 1/1/5 Ten-GigabitEthernet 2/1/5
port link-aggregation group 1
quit

Теперь остается подключиться к третьему коммутатору, с которым настроена агрегация каналов, и включить на нем lacp mad-passthrough. Как именно она включается — зависит от модели коммутатора.

Настройка ARP MAD

Для настройки ARP MAD потребуется только общий VLAN между коммутаторами для запросов Gratuitous ARP.

Создадим отдельный VLAN:

vlan 1001
description ARP_MAD
quit

настроим Vlan:

interface vlan-interface 1001
ip address 10.20.100.1 255.255.255.252
mad arp enable
quit

Настроим Vlan на портах (аналогично настройке BFD MAD):
interface range Ten-GigabitEthernet 1/0/18 Ten-GigabitEthernet 2/0/18
port link-mode bridge
port link-type hybrid
port hybrid vlan 1001 untagged
port hybrid pvid vlan 1001

ARP MAD настроен.

Проверка состояния MAD

Посмотреть какой тип MAD включен можно с помощью команды:

display mad

Проверить состояние MAD можно с помощью команды:

display mad verbose

Теперь, в созданном и отказоустойчивом виртуальном шасси можно настраивать Vlan, порты и т.д., как это сделать — описывается в статье: Настройка интерфейсов в коммутаторах H3C (HP) (Comware Software).

Заказать создание и поддержку безопасной IT-инфраструктуры любой сложности

Быть уверенным в своей IT-инфраструктуре — это быть уверенным в завтрашнем дне.

Для того, чтобы сделать заказ:

Заполните форму обратной связи и мы обязательно с вам свяжемся:
Форма обратной связи
Позвоните нам по телефону:
+7(909)952-44-33
Напишите нам на электронную почту:
order@blackdiver.net
Напишите нам в Telegram:
Telegram
Другие способы связи Вы сможете найти в разделе Контакты.