Коммутаторы Cisco. настройка VLAN на портах и базовой маршрутизации

Сегодня мы настроим на оборудовании Cisco VLAN и соединим два ПК в общую сеть.

Принципиальная схема сети 1

Перейдем в привилегированный режим.
enable

Перейдем в режим конфигурации.

configure terminal

Создадим VLAN 2 и назовем его test

vlan 2
name test


Теперь закончим конфигурирование VLAN

exit

Выберем интерфейсы, которые будем конфигурировать под этот VLAN:
(Диапазон интерфейсов указывается командой range)

interface range fastEthernet 0/23 - 24

переведем интерфейсы в режим доступа:

switchport mode access

Укажем, что они относятся к VLAN 2:

switchport access vlan 2

и теперь включим их:

no shutdown

На этом самая простая конфигурация закончена. Компьютеры TEST_PC0 и TEST_PC1 видят друг-друга. Это можно проверить запустив пинг.

Теперь добавим еще один VLAN

Принципиальная схема сети 2

vlan 3
name test1

Сконфигурируем интерфейсы:

interface range fastEthernet 0/21 - 22
switchport mode access
switchport access vlan 2
no shutdown

Теперь у нас есть два VLAN, но мы не можем маршрутизировать траффик между ними на коммутаторе L2. Для маршрутизации нам требуется коммутатор L3 или внешнее устройство, которое может маршрутизировать трафик (маршрутизатор).

Заменим коммутатор L2 на коммутатор L3. Все остальные настройки оставим такими же.

Принципиальная схема сети 3

Теперь можно включить маршрутизацию между VLAN‘ами.

ip routing

Но для маршрутизации нужно задать адреса каждого VLAN:
VLAN 2 — 10.10.10.1

interface vlan 2
ip address 10.10.10.1

и для VLAN 3 — 10.10.11.1

interface vlan 3
ip address 10.10.11.1

Остается только эти адреса прописать в качестве шлюза на всех ПК и они будут видеть друг-друга.

Теперь добавим маршрутизатор.

Принципиальная схема сети 3

Переведем один из портов коммутатора в режим L3. Через него мы будем маршрутизировать весь трафик от VLAN 2 и VLAN 3

interface fastEthernet 0/1
no switchport
ip address 192.168.0.2 255.255.255.0
no shutdown

И настроим маршрут по умолчанию на самом коммутаторе:

ip route 0.0.0.0 0.0.0.0 192.168.0.1

Остается на маршрутизаторе настроить адрес.

interface gigabitEthernet 0/2
ip address 192.168.0.1 255.255.255.0
no shutdown

и обратные маршруты (обратные маршруты на маршрутизаторе нужно прописывать потому что у нас внутри сети только чистая маршрутизация):

ip route 10.10.10.0 255.255.255.0 192.168.0.2
ip route 10.10.11.0 255.255.255.0 192.168.0.2

На этом построение сети закончено.
Список всех VLAN можно посмотреть командой:

show vlan

Продолжение цикла статей, в которых мы настраиваем сеть:
2) Cisco. Настройка EtherChannel между коммутаторами
3) Cisco. Создание статических trunk портов
4)Cisco. Настройка VTP

Заказать создание и поддержку безопасной IT-инфраструктуры любой сложности

Быть уверенным в своей IT-инфраструктуре — это быть уверенным в завтрашнем дне.

Для того, чтобы сделать заказ:

Заполните форму обратной связи и мы обязательно с вам свяжемся:
Форма обратной связи
Позвоните нам по телефону:
+7(909)952-44-33
Напишите нам на электронную почту:
order@blackdiver.net
Напишите нам в Telegram:
Telegram
Другие способы связи Вы сможете найти в разделе Контакты.